Login | Register
My pages Projects Community openCollabNet

Chapter 10.  The Menu bar

Table of Contents

10.1. Introduction
10.2. Mouse Behavior in the Menu Bar
10.3. The File Menu
10.3.1. New
10.3.2. Open Project...
10.3.3. Save Project
10.3.4. Save Project As...
10.3.5. Revert to Saved
10.3.6. Import XMI...
10.3.7. Export XMI...
10.3.8. Import Sources...
10.3.9. Page Setup...
10.3.10. Print...
10.3.11. Export Graphics...
10.3.12. Export All Graphics...
10.3.13. Notation
10.3.14. Project Properties
10.3.15. Most Recent Used Files
10.3.16. Exit
10.4. The Edit Menu
10.4.1. Select
10.4.2. Remove From Diagram
10.4.3. Delete From Model
10.4.4. Configure Perspectives...
10.4.5. Settings...
10.5. The View Menu
10.5.1. Goto Diagram...
10.5.2. Find...
10.5.3. Zoom
10.5.4. Adjust Grid
10.5.5. Adjust Snap
10.5.6. Page Breaks
10.5.7. Toolbars
10.5.8. XML Dump
10.6. The Create Menu
10.6.1. New Use Case Diagram
10.6.2. New Class Diagram
10.6.3. New Sequence Diagram
10.6.4. New Collaboration Diagram
10.6.5. New Statechart Diagram
10.6.6. New Activity Diagram
10.6.7. New Deployment Diagram
10.7. The Arrange Menu
10.7.1. Align
10.7.2. Distribute
10.7.3. Reorder
10.7.4. Size To Fit Contents
10.7.5. Layout
10.8. The Generation Menu
10.8.1. Generate Selected Classes ...
10.8.2. Generate All Classes...
10.8.3. Generate Code for Project... (To be Written)
10.8.4. Settings for Generate for Project... (To be Written)
10.9. The Critique Menu
10.9.1. Toggle Auto-Critique
10.9.2. Design Issues...
10.9.3. Design Goals...
10.9.4. Browse Critics...
10.10. The Tools Menu
10.11. The Help Menu
10.11.1. System Information
10.11.2. About ArgoUML

10.1.  Introduction

An important principle behind ArgoUML is that actions should be able to be invoked in whatever way the user finds convenient. As a result many (but not all) actions that can be carried out on the menu can be carried out in other ways as well under ArgoUML.

A number of the common menu entries are also available through keyboard shortcuts.

It is also be possible to navigate the menu from the keyboard. Each level of each menu is identified by a letter (shown underlined in the menu or entry name from the moment the ALT key is pressed). This sequence of letters while holding down the ALT key selects the entry.

The following is an explanation of why the menuitems are grouped as they are.

  • The File menu contains operations that affect on the whole project/file. All the items in this menu can be explained as such.

  • The Edit menu is generally intended for editing the model or changing the content of a diagram. It also contains functions to enable editing, like e.g. selecting. This menu is not intended for diagram layout functions. Most functions here do something with the selected modelelement and diagram. The items "Configure Perspectives..." and "Settings..." are a bit different, since they adjust the way ArgoUML works - but they do not belong in the File menu, since their settings are not stored in the project.

  • The View menu is for functions that do never alter the model, nor the diagram layout, only the way you view the diagram. A good example is "zoom". Also navigational functions belong here, e.g. "Find" and "Goto Diagram...". All changes of settings in this menu apply to all diagrams (e.g. zoom).

  • The Create menu contains all possible diagrams that can be created. These functions are context dependend, since they work on the selected modelelement.

  • The Arrange menu allows layout changes in the current diagram, which is not the same as the items in the View menu. Functions here can not alter the UML model.

  • The Generation menu is for Code Generation. The functions here work either on the selected modelelements, or on the whole project.

  • The Critique menu is specific for settings related to critics, which apply for all projects.

  • The Tools menu is currently empty. If plugins are installed, then their functions appear here.

  • The Help menu contains the usual "information" and "about".