Login | Register
My pages Projects Community openCollabNet

Chapter 10. The Menu bar

10.1. Introduction

An important principle behind ArgoUML is that actions should be able to be invoked in whatever way the user finds convenient. As a result many (but not all) actions that can be carried out on the menu can be carried out in other ways as well under ArgoUML.

A number of the common menu entries are also available through keyboard shortcuts.

It is also be possible to navigate the menu from the keyboard. Each level of each menu is identified by a letter (shown underlined in the menu or entry name from the moment the ALT key is pressed). This sequence of letters while holding down the ALT key selects the entry.

The following is an explanation of why the menuitems are grouped as they are.

  • The File menu contains operations that affect on the whole project/file. All the items in this menu can be explained as such.

  • The Edit menu is generally intended for editing the model or changing the content of a diagram. It also contains functions to enable editing, like e.g. selecting. This menu is not intended for diagram layout functions. Most functions here do something with the selected modelelement and diagram. The items "Configure Perspectives..." and "Settings..." are a bit different, since they adjust the way ArgoUML works - but they do not belong in the File menu, since their settings are not stored in the project.

  • The View menu is for functions that do never alter the model, nor the diagram layout, only the way you view the diagram. A good example is "zoom". Also navigational functions belong here, e.g. "Find" and "Goto Diagram...". All changes of settings in this menu apply to all diagrams (e.g. zoom).

  • The Create menu contains all possible diagrams that can be created. These functions are context dependend, since they work on the selected modelelement.

  • The Arrange menu allows layout changes in the current diagram, which is not the same as the items in the View menu. Functions here can not alter the UML model.

  • The Generation menu is for Code Generation. The functions here work either on the selected modelelements, or on the whole project.

  • The Critique menu is specific for settings related to critics, which apply for all projects.

  • The Tools menu is currently empty. If plugins are installed, then their functions appear here.

  • The Help menu contains the usual "information" and "about".